如果你在UOS统一操作系统下面安装搜狗输入法报错,错误内如如下:

Selecting previously unselected package sogoupinyin.
(Reading database ... 207682 files and directories currently installed.)
Preparing to unpack .../sogoupinyin_2.3.1.0112_amd64.deb ...
Unpacking sogoupinyin (2.3.1.0112) ...
Processing triggers for libglib2.0-0:i386 (2.58.3.4-1+deepin) ...
Processing triggers for libglib2.0-0:amd64 (2.58.3.4-1+deepin) ...
Processing triggers for lastore-daemon (5.0.6-1) ...
Processing triggers for desktop-file-utils (0.23-4) ...
Processing triggers for bamfdaemon (0.5.4-1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.62) ...
Processing triggers for shared-mime-info (1.10-1) ...
Processing triggers for fontconfig (2.13.1-2) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
An error occurred while applying changes: dpkg: dependency problems prevent configuration of sogoupinyin:
sogoupinyin depends on fonts-droid | fonts-droid-fallback; however:
Package fonts-droid is not installed.
Package fonts-droid-fallback is not installed.
sogoupinyin depends on libopencc2 | libopencc1; however:
Package libopencc2 is not installed.
Package libopencc1 is not installed.

dpkg: error processing package sogoupinyin (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
sogoupinyin

出现这个问题的原因是因为依赖包没有正确安装,使用下面的命令安装依赖包后即可。

sudo apt install fonts-droid-fallback

sudo apt –fix-broken install

然后重启电脑

Scroll to Top